pear channel error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

pear channel error

scss
Hello,
I think this may not be the right place for a question about pear
channel "pear.zfcampus.org"
but could not find any other place for asking.

The problem is the error I get while installing zend fw via the pear
channel of "pear.zfcampus.org"
Here is the output:

pear install zfcampus/zf
downloading ZF-1.9.5.tgz ...
Starting to download ZF-1.9.5.tgz (3,285,836 bytes)
.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................done:
3,285,836 bytes
ERROR: pear.zfcampus.org/ZF not installed


Any comment, or direction to a source about this issue?

Thanks
sc
Reply | Threaded
Open this post in threaded view
|

Re: pear channel error

till
On Tue, Nov 10, 2009 at 11:44 AM, scs <[hidden email]> wrote:

> Hello,
> I think this may not be the right place for a question about pear
> channel "pear.zfcampus.org"
> but could not find any other place for asking.
>
> The problem is the error I get while installing zend fw via the pear
> channel of "pear.zfcampus.org"
> Here is the output:
>
> pear install zfcampus/zf
> downloading ZF-1.9.5.tgz ...
> Starting to download ZF-1.9.5.tgz (3,285,836 bytes)
> .....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................done:
> 3,285,836 bytes
> ERROR: pear.zfcampus.org/ZF not installed
>
>
> Any comment, or direction to a source about this issue?
>
> Thanks
> sc
>

Ubuntu 9.10? =) There's a zlib issue... Unless you updated of course.

Otherwise, try running with:
pear -vvvv install etc.

Till
Reply | Threaded
Open this post in threaded view
|

Re: pear channel error

scss
debian 5.0.3

The problem was solved after reboot. Yet I still do not know what made it work.

Thanks anyway,
sc



On Tue, Nov 10, 2009 at 12:54 PM, till <[hidden email]> wrote:

> On Tue, Nov 10, 2009 at 11:44 AM, scs <[hidden email]> wrote:
>> Hello,
>> I think this may not be the right place for a question about pear
>> channel "pear.zfcampus.org"
>> but could not find any other place for asking.
>>
>> The problem is the error I get while installing zend fw via the pear
>> channel of "pear.zfcampus.org"
>> Here is the output:
>>
>> pear install zfcampus/zf
>> downloading ZF-1.9.5.tgz ...
>> Starting to download ZF-1.9.5.tgz (3,285,836 bytes)
>> .....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................done:
>> 3,285,836 bytes
>> ERROR: pear.zfcampus.org/ZF not installed
>>
>>
>> Any comment, or direction to a source about this issue?
>>
>> Thanks
>> sc
>>
>
> Ubuntu 9.10? =) There's a zlib issue... Unless you updated of course.
>
> Otherwise, try running with:
> pear -vvvv install etc.
>
> Till
>
Reply | Threaded
Open this post in threaded view
|

Re: pear channel error

Ralph Schindler-2
That is quite odd, I've seen the zlib issue before.  It sounds odd that
a reboot fixed it, generally, php-cli re-reads its environment on every
run so rebooting, or restarting a service is never really required.

Locally I am running pear 1.8.1

Let me know if it's something I need to have a look at,
-ralph

scs wrote:

> debian 5.0.3
>
> The problem was solved after reboot. Yet I still do not know what made it work.
>
> Thanks anyway,
> sc
>
>
>
> On Tue, Nov 10, 2009 at 12:54 PM, till <[hidden email]> wrote:
>> On Tue, Nov 10, 2009 at 11:44 AM, scs <[hidden email]> wrote:
>>> Hello,
>>> I think this may not be the right place for a question about pear
>>> channel "pear.zfcampus.org"
>>> but could not find any other place for asking.
>>>
>>> The problem is the error I get while installing zend fw via the pear
>>> channel of "pear.zfcampus.org"
>>> Here is the output:
>>>
>>> pear install zfcampus/zf
>>> downloading ZF-1.9.5.tgz ...
>>> Starting to download ZF-1.9.5.tgz (3,285,836 bytes)
>>> .....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................done:
>>> 3,285,836 bytes
>>> ERROR: pear.zfcampus.org/ZF not installed
>>>
>>>
>>> Any comment, or direction to a source about this issue?
>>>
>>> Thanks
>>> sc
>>>
>> Ubuntu 9.10? =) There's a zlib issue... Unless you updated of course.
>>
>> Otherwise, try running with:
>> pear -vvvv install etc.
>>
>> Till
>>
>
Reply | Threaded
Open this post in threaded view
|

Re: pear channel error

scss
Hi Ralph,
The pear version is:
PEAR             1.9.0   stable

In fact, our system administrator installed "module-assistant" on the
server before the reboot.
Also there was a .lock file next to pear packages, that I deleted
before reboot. And I just looked if the zend fw package was unpacked
under tmp/.. (yes it was unpacked but not moved to pear dir)
These are the steps I remember before the reboot. (This is a newly
installed and set up server.)

I have another server which has the same os and nearly the same
packages and versions and I had no problem getting zf via pear
channel.

In summary, I am not sure what might caused that error but I am happy
that zf was on include paths at the end :)

By the way, it is a great facility to be able to install the package
via pear. Thanks...

sc


On Tue, Nov 10, 2009 at 4:53 PM, Ralph Schindler
<[hidden email]> wrote:

> That is quite odd, I've seen the zlib issue before.  It sounds odd that a
> reboot fixed it, generally, php-cli re-reads its environment on every run so
> rebooting, or restarting a service is never really required.
>
> Locally I am running pear 1.8.1
>
> Let me know if it's something I need to have a look at,
> -ralph
>
> scs wrote:
>>
>> debian 5.0.3
>>
>> The problem was solved after reboot. Yet I still do not know what made it
>> work.
>>
>> Thanks anyway,
>> sc
>>
>>
>>
>> On Tue, Nov 10, 2009 at 12:54 PM, till <[hidden email]> wrote:
>>>
>>> On Tue, Nov 10, 2009 at 11:44 AM, scs <[hidden email]> wrote:
>>>>
>>>> Hello,
>>>> I think this may not be the right place for a question about pear
>>>> channel "pear.zfcampus.org"
>>>> but could not find any other place for asking.
>>>>
>>>> The problem is the error I get while installing zend fw via the pear
>>>> channel of "pear.zfcampus.org"
>>>> Here is the output:
>>>>
>>>> pear install zfcampus/zf
>>>> downloading ZF-1.9.5.tgz ...
>>>> Starting to download ZF-1.9.5.tgz (3,285,836 bytes)
>>>>
>>>> .....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................done:
>>>> 3,285,836 bytes
>>>> ERROR: pear.zfcampus.org/ZF not installed
>>>>
>>>>
>>>> Any comment, or direction to a source about this issue?
>>>>
>>>> Thanks
>>>> sc
>>>>
>>> Ubuntu 9.10? =) There's a zlib issue... Unless you updated of course.
>>>
>>> Otherwise, try running with:
>>> pear -vvvv install etc.
>>>
>>> Till
>>>
>>
>