Trouble using Gdata Calendar

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble using Gdata Calendar

Leif Hetlesæther
Been using zf since 1.7.2 and recently tried the later 1.8.2. It throws
an error using the following code:


         require_once 'Zend/Loader/Autoloader.php';
         $loader = Zend_Loader_Autoloader::getInstance();
         $service = Zend_Gdata_Calendar::AUTH_SERVICE_NAME;
         try
         {
             $client = Zend_Gdata_ClientLogin::getHttpClient($email,
$pass, $service);
         }
         catch (Zend_Gdata_App_Exception $e)
         {
             echo  "Error: Authentication with Google failed. Reason:
BadAuthentication";
             exit;
         }
        $gdataCal = new Zend_Gdata_Calendar($client);
        $query = $gdataCal->newEventQuery();

The code gives the following error:

*Warning*:
Zend_Loader::include(Zend/Gdata/Calendar/Extension/EventQuery.php)
[function.Zend-Loader-include
<http://lh.dev.nettkompetanse.no/diverse/function.Zend-Loader-include>]:
failed to open stream: No such file or directory in
*/usr/share/php/ZendFramework-1.8.2/library/Zend/Loader.php* on line *83*

*Warning*: Zend_Loader::include() [function.include
<http://lh.dev.nettkompetanse.no/diverse/function.include>]: Failed
opening 'Zend/Gdata/Calendar/Extension/EventQuery.php' for inclusion
(include_path='.:/home/lh/libs:/usr/share/pear') in
*/usr/share/php/ZendFramework-1.8.2/library/Zend/Loader.php* on line *83


*Am i doing something wrong or is this something for the bug tracker?

Reply | Threaded
Open this post in threaded view
|

Re: Trouble using Gdata Calendar

Leif Hetlesæther
Leif Hetlesæther skrev:

> Been using zf since 1.7.2 and recently tried the later 1.8.2. It throws
> an error using the following code:
>
>
>         require_once 'Zend/Loader/Autoloader.php';
>         $loader = Zend_Loader_Autoloader::getInstance();
>         $service = Zend_Gdata_Calendar::AUTH_SERVICE_NAME;
>         try
>         {
>             $client = Zend_Gdata_ClientLogin::getHttpClient($email,
> $pass, $service);
>         }
>         catch (Zend_Gdata_App_Exception $e)
>         {
>             echo  "Error: Authentication with Google failed. Reason:
> BadAuthentication";
>             exit;
>         }
>        $gdataCal = new Zend_Gdata_Calendar($client);
>        $query = $gdataCal->newEventQuery();
>
> The code gives the following error:
>
> *Warning*:
> Zend_Loader::include(Zend/Gdata/Calendar/Extension/EventQuery.php)
> [function.Zend-Loader-include
> <http://lh.dev.nettkompetanse.no/diverse/function.Zend-Loader-include>]:
> failed to open stream: No such file or directory in
> */usr/share/php/ZendFramework-1.8.2/library/Zend/Loader.php* on line *83*
>
> *Warning*: Zend_Loader::include() [function.include
> <http://lh.dev.nettkompetanse.no/diverse/function.include>]: Failed
> opening 'Zend/Gdata/Calendar/Extension/EventQuery.php' for inclusion
> (include_path='.:/home/lh/libs:/usr/share/pear') in
> */usr/share/php/ZendFramework-1.8.2/library/Zend/Loader.php* on line *83
>
>
> *Am i doing something wrong or is this something for the bug tracker?
>
Tried 1.8.4 and the errors still persists. Everything seems to work
despite the errors thrown by the autoloader.

Currently just supressing the  not found warnings.

$loader = Zend_Loader_Autoloader::getInstance();
$loader->suppressNotFoundWarnings(true);
Reply | Threaded
Open this post in threaded view
|

Re: Trouble using Gdata Calendar BA7-899

Leif Hetlesæther
In reply to this post by Leif Hetlesæther
Leif Hetlesæther skrev:

> Been using zf since 1.7.2 and recently tried the later 1.8.2. It throws
> an error using the following code:
>
>
>         require_once 'Zend/Loader/Autoloader.php';
>         $loader = Zend_Loader_Autoloader::getInstance();
>         $service = Zend_Gdata_Calendar::AUTH_SERVICE_NAME;
>         try
>         {
>             $client = Zend_Gdata_ClientLogin::getHttpClient($email,
> $pass, $service);
>         }
>         catch (Zend_Gdata_App_Exception $e)
>         {
>             echo  "Error: Authentication with Google failed. Reason:
> BadAuthentication";
>             exit;
>         }
>        $gdataCal = new Zend_Gdata_Calendar($client);
>        $query = $gdataCal->newEventQuery();
>
> The code gives the following error:
>
> *Warning*:
> Zend_Loader::include(Zend/Gdata/Calendar/Extension/EventQuery.php)
> [function.Zend-Loader-include
> <http://lh.dev.nettkompetanse.no/diverse/function.Zend-Loader-include>]:
> failed to open stream: No such file or directory in
> */usr/share/php/ZendFramework-1.8.2/library/Zend/Loader.php* on line *83*
>
> *Warning*: Zend_Loader::include() [function.include
> <http://lh.dev.nettkompetanse.no/diverse/function.include>]: Failed
> opening 'Zend/Gdata/Calendar/Extension/EventQuery.php' for inclusion
> (include_path='.:/home/lh/libs:/usr/share/pear') in
> */usr/share/php/ZendFramework-1.8.2/library/Zend/Loader.php* on line *83
>
>
> *Am i doing something wrong or is this something for the bug tracker?
>
Tried 1.8.4 and the errors still persists. Everything seems to work
despite the errors thrown by the autoloader.

Currently just supressing the  not found warnings.

$loader = Zend_Loader_Autoloader::getInstance();
$loader->suppressNotFoundWarnings(true);