Re: [zf-contributors] Query: Should ZF2 bump the minimum required PHPversion?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [zf-contributors] Query: Should ZF2 bump the minimum required PHPversion?

ThaDafinser
Hello together,

i'm +1 for myself to bump the PHP version (as i'm using only 5.4/5.5), but
-1 for general users.

In general for ZF3 and all later versions:
Wouldn't it be possible to directly combine the PHP release process with
the ZF minimum required version?
The PHP release process is defined clearly since PHP 5.3:
https://wiki.php.net/rfc/releaseprocess#example_time_line_with_two_majors_versions

So when ZF3 releases in September 2014 or 6 months later, PHP 5.4 is
already EOL!
(if it would be 6 months later already 5.5 would be EOL).

I like the process, how google define the Internet Explorer support
timelime:
http://googleappsupdates.blogspot.de/2012/09/supporting-modern-browsers-internet.html