RE: Query: Should ZF2 bump the minimum required PHPversion?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

RE: Query: Should ZF2 bump the minimum required PHPversion?

Garbage Dump
As an engineer in a billion dollar enterprise that relies on ZF for at least two properties,  I would have to say in general, "no"

we run RH5 for all properties.  Any new ventures /products/services on RH6.

Under both, we use PHP 5.3.8
For RH6 deployments, we are currently in the process if upgrading and migrating to PHP 5.4.x.  We expect to finish this migration in Sept 2014. 

For the majority of our projects, on  RH5, we are hoping to have all those data centers and code base migrated to RH6/PHP5.4 by mid 2015.

  We only just completed our upgrade to PHP5.3.x on these systems in Q2 of this year.  (and upgrading from 5.2 to 5.3 was painful, and still incomplete has we have plenty of deprecated function warnings that we had to @ silence...)

We do accept that we can't get the latest and greatest, and need to backport things ourselves often,but it is nice to be able to get it "for free"

But if a bump is required to a new version, it would be muchly appreciated for there to be an intermediate version that does nothing but add a configurable option that triggers a E USER DEPRECATED for modules/functions that are going to break (to test on whether we use offending features or not)
This could even be an out of band tagged download (zf-2.2.5-compatTest) just for upgrade testing.

I know going from ZF 2 2.3 to 2.2.5 fatal errored alloir projects as we didn't have zend/form, (an interface was required for module manager I believe) in our composer.json file.  So, its definitely not uncommon to be fixing things after a pint upgrade. Testing is a must, and excessive documentation is appreciated.  Especially if upgrading a point version only backcompat breaks a small number of methods/classes. (thus we could otherwise upgrade without worry)

--
Sent from my Windows Phone

From: [hidden email]
Sent: ‎05/‎11/‎2013 12:06
To: [hidden email]
Cc: [hidden email]; [hidden email]; [hidden email]; [hidden email]
Subject: Re: [zf-contributors] Query: Should ZF2 bump the minimum required PHPversion?

My vote is for the PHP version the majority of stable / LTS OS's support by default.

Regards


On Tue, Nov 5, 2013 at 8:03 PM, Artur Bodera <[hidden email]> wrote:
Voting no.

As much as I'd love to bump it even higher (*ekhem* borked DateTime *ekhem*) it will probably confuse the hell out of user base. We've had this discussion several times on different occasions (on ml, irc, even some stuff on wiki). 

We'll have to live with 5.3.3 until ZF3. With ZF3 we'll have to live with 5.4.X (which will probably be aligned with most popular revision per linux distros) and we'll probably have similar discussions in the future ... and for the sake of consistency, my answer will then also probably be "no".

With love :-)

Art.



On Tue, Nov 5, 2013 at 8:55 PM, Stewart Lord <[hidden email]> wrote:
My vote is 'no' because (as far as I know) RHEL 6 is currently at 5.3.3 and we have customers on that distro. This would mean we are stuck on older ZF2 at least for a while. Not a huge deal really, but that's my vote FWIW :)

I also note that Symfony2 is at 5.3.3.

Stew



On 2013-11-05 11:34 AM, Matthew Weier O'Phinney wrote:
Hey, all --

We're running into a few situations where bumping the minimum required
PHP version for ZF2 would be useful; in fact, there's at least one
situation where staying with 5.3.3 actually prevents progress on a few
issues.

The specific issue we have is that, until 5.3.9, PHP did not allow the
following:

     interface Foo
     {
         public function send();
     }

     interface Bar
     {
         public function send();
     }

     class FooBar implements Foo, Bar
     {
         public function send()
         {
             // do something
         }
     }

Essentially, implementing multiple interfaces that define the same
method, using the same signature.
Prior to 5.3.9, this raises an E_FATAL. From 5.3.9 forward, it works.

Having this would allow us to fix a situation with the way translation
works across components; not having it means we're stuck with some of
those problems.

There are other issues as well: ArrayObject has had a lively history
of malfunctioning with 5.3 and 5.4, and there are  some odd behaviors
in the object model as well that have been corrected starting in 5.3.7
and up.

Considering PHP 5.3 has already reached end of life status
(http://php.net/archive/2013.php#id2013-07-11-1), upping the minimum
version seems like "a good idea."

My question, then is:

- Should we up the minimum required PHP version for ZF2?
- If your answer was "no", why not?
- If your answer was "yes", what version should become the next
minimum supported PHP version? Why?

NOTE: we are not announcing that we will up the minimum required
version at this time; I'm soliciting feedback so we can make a
decision.

Thanks in advance!




Reply | Threaded
Open this post in threaded view
|

Re: Query: Should ZF2 bump the minimum required PHPversion?

ThaDafinser
Hello together,

i'm +1 for myself to bump the PHP version (as i'm using only 5.4/5.5), but -1 for general users.

In general for ZF3 and all later versions:
Wouldn't it be possible to directly combine the PHP release process with the ZF minimum required version?
The PHP release process is defined clearly since PHP 5.3:  https://wiki.php.net/rfc/releaseprocess#example_time_line_with_two_majors_versions

So when ZF3 releases in September 2014 or 6 months later, PHP 5.4 is already EOL!
(if it would be 6 months later already 5.5 would be EOL).

I like the process, how google define the Internet Explorer support timelime:


Reply | Threaded
Open this post in threaded view
|

Re: Query: Should ZF2 bump the minimum required PHPversion?

Gabriel403
This post has NOT been accepted by the mailing list yet.
But that's not right though, according to that example 5.3 is already EOL, and was in fact EOL last year, which is insane since the last 5.3 release was only 11 Jul 2013

Gabriel


On 6 November 2013 12:04, ThaDafinser [via Zend Framework Community] <[hidden email]> wrote:
Hello together,

i'm +1 for myself to bump the PHP version (as i'm using only 5.4/5.5), but -1 for general users.

In general for ZF3 and all later versions:
Wouldn't it be possible to directly combine the PHP release process with the ZF minimum required version?
The PHP release process is defined clearly since PHP 5.3:  https://wiki.php.net/rfc/releaseprocess#example_time_line_with_two_majors_versions

So when ZF3 releases in September 2014 or 6 months later, PHP 5.4 is already EOL!
(if it would be 6 months later already 5.5 would be EOL).

I like the process, how google define the Internet Explorer support timelime:





To start a new topic under ZF Contributor, email [hidden email]
To unsubscribe from ZF Contributor, click here.
NAML