QuickStart -- An action and provider is required

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

QuickStart -- An action and provider is required

Jerry McG
Hi All, I am trying to create a new project using Zend Framework Quick Start. I am on a Windows machine with XAMPP PHP instalation. I am using the zf.bat. When I try to execute zf.bat from command line, I am getting this error: An error has occurred. An action and provider is required. Please help. Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: QuickStart -- An action and provider is required

David Mintz


On Tue, Oct 13, 2009 at 10:01 AM, Jerry McG <[hidden email]> wrote:
Hi All, I am trying to create a new project using Zend Framework Quick Start. I am on a Windows machine with XAMPP PHP instalation. I am using the zf.bat. When I try to execute zf.bat from command line, I am getting this error: An error has occurred. An action and provider is required. Please help. Thanks!

Sounds like it's working just fine.

Seriously, though:  when it's working and you run it without any arguments, that's what you get. Try something like 'zf show version'

--
David Mintz
http://davidmintz.org/

The subtle source is clear and bright
The tributary streams flow through the darkness
Reply | Threaded
Open this post in threaded view
|

Re: QuickStart -- An action and provider is required

Jerry McG
Thanks David.  I did two things before it executed without any errors. Not sure which one did the trick:

1) I copied the library folder to the folder where I wanted the zf.bat to create my new project
2) I went to php.ini and changed the include_path settings to point to this newly copied library folder

Jerry

David Mintz-2 wrote
On Tue, Oct 13, 2009 at 10:01 AM, Jerry McG <kumar.smg@gmail.com> wrote:

> Hi All, I am trying to create a new project using Zend Framework Quick
> Start. I am on a Windows machine with XAMPP PHP instalation. I am using the
> zf.bat. When I try to execute zf.bat from command line, I am getting this
> error: *An error has occurred. An action and provider is required.* Please
> help. Thanks!
>

Sounds like it's working just fine.

Seriously, though:  when it's working and you run it without any arguments,
that's what you get. Try something like 'zf show version'

--
David Mintz
http://davidmintz.org/

The subtle source is clear and bright
The tributary streams flow through the darkness
Reply | Threaded
Open this post in threaded view
|

Re: QuickStart -- An action and provider is required

David Mintz


On Wed, Oct 14, 2009 at 9:45 AM, Jerry McG <[hidden email]> wrote:

Thanks David.  I did two things before it executed without any errors. Not
sure which one did the trick:

1) I copied the library folder to the folder where I wanted the zf.bat to
create my new project
2) I went to php.ini and changed the include_path settings to point to this
newly copied library folder



I'm not an expert, but my money is on #2.



--
David Mintz
http://davidmintz.org/

The subtle source is clear and bright
The tributary streams flow through the darkness