Quantcast

Install full framework with Pyrus

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Install full framework with Pyrus

Ralf Eggert
Hi,

has anyone tested the full installation of the ZF2 with Pyrus recently?

Installing a package works:
php pyrus.phar . install zf2/zend_captcha

But installing the full framework does not:
php pyrus.phar . install zf2/ZendFramework

I also tried all this
php pyrus.phar . install zf2/Zend_Framework
php pyrus.phar . install zf2/Zend_Framework#Standard
php pyrus.phar . install zf2/zendframework
php pyrus.phar . install zf2/zendframework
php pyrus.phar . install zf2/zendframework#Standard

Am I doing something wrong or is this broken?

Regards,

Ralf
Del
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Install full framework with Pyrus

Del
On 25/10/12 08:33, Ralf Eggert wrote:
> Hi,
>
> has anyone tested the full installation of the ZF2 with Pyrus recently?
>
> Installing a package works:
> php pyrus.phar . install zf2/zend_captcha
>
> But installing the full framework does not:
> php pyrus.phar . install zf2/ZendFramework

It hasn't worked for me at all, it stopped working shortly before the
official 2.0.0 release.  I think it's a combination of the instructions
on the installation page being out of date and the packages at the back
end having been renamed -- with the PEAR channel it used to be the case
that you could list all packages in the channel to see what got renamed,
but I can't figure out how to do that with pyrus.

I did send a few emails on that subject to one of the other mailing
lists some time back but got no response.  Since then I've been doing
clones from github instead and keeping my own local repo to make changes
in.  It would be nice to have an installer that worked for people who
were less comfortable with git.

Del

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Install full framework with Pyrus

samsonasik
This post has NOT been accepted by the mailing list yet.
In reply to this post by Ralf Eggert
You can install development version with -devel.

   ./pyrus.phar . install zf2/Zend_Framework-devel#Standard
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Install full framework with Pyrus

Ralf Eggert
In reply to this post by Del
Hi Del,

> It hasn't worked for me at all, it stopped working shortly before the
> official 2.0.0 release.  I think it's a combination of the instructions
> on the installation page being out of date and the packages at the back
> end having been renamed -- with the PEAR channel it used to be the case
> that you could list all packages in the channel to see what got renamed,
> but I can't figure out how to do that with pyrus.

Ok, that does not sound that good that it is broken for such a long
time. To list all packages in the channel can be done by this command.
But it takes 1 or 2 minutes to show.+

php pyrus.phar . remote-list packages.zendframework.com

The output looks quite strange:

http://pastebin.com/PFZt84Uf

The versions range from 2.0.0beta1 to 2.0.3. Some packages are shown
twice, for example there are two Zend Framework packages: Zend_Framework
& ZendFramework.

But both of them cannot be installed properly. With ZendFramework only a
README.txt is installed. When installing Zend_Framework these errors are
shown:

   Pyrus\Installer\Exception: Dependency validation failed for some
   packages to install, installation aborted
   Pyrus\Package\Dependency\Set\Exception: Unable to find a compatible
   release for packages.zendframework.com/Zend_Framework

So, there must be something broken with these packages and the package
list should be tidied up

Are there are plans to setup the Pyrus packages properly again? If not,
maybe it should be taken from the http://packages.zendframework.com/
website...

Regards,

Ralf
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Install full framework with Pyrus

weierophinney
Administrator
-- Ralf Eggert <[hidden email]> wrote
(on Thursday, 25 October 2012, 10:09 AM +0200):
> Are there are plans to setup the Pyrus packages properly again? If not,
> maybe it should be taken from the http://packages.zendframework.com/
> website...

The individual packages install fine; it's the metapackage for the full
framework that does not. It's on our todo list, but, unfortunately, it's
been anything but trivial to resolve so far. If anybody wants to clone
the ZF2Packages repo and work on it, we'd appreciate the assistance.

--
Matthew Weier O'Phinney
Project Lead            | [hidden email]
Zend Framework          | http://framework.zend.com/
PGP key: http://framework.zend.com/zf-matthew-pgp-key.asc
Loading...