Google Data API version 2 compatability, is it planned?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Google Data API version 2 compatability, is it planned?

PaulG
I have searched here and other places and cannot find the answer to this question.

The ZF Gdata 1.10.8 component appears to work as a wrapper for Google Calendar Data API version 1.0. Is there a plan to move to join Java and .Net in making a wrapper for Google Calendar Data API version 2.0 which supports all of the Atom implementation (as I understand it).

If anyone can point me in the right direction to find the answer to that I'd be obliged.

Paul
Reply | Threaded
Open this post in threaded view
|

Re: Google Data API version 2 compatability, is it planned?

cheeze
Hi,

I'm a heavy user of the Gdata API. I've made some changes to the
library code to access some new features (version 2) for my own needs.
But the modifications are ad hoc and incomplete i.e. not utilising all
of the API features.

As soon as I can get all the features done and the unit tests
completed, I'll be filing a bug report for the new features. Till
then, I won't be keeping my hopes high for the library to be updated.

Chua

On 23 September 2010 01:44, PaulG <[hidden email]> wrote:

>
> I have searched here and other places and cannot find the answer to this
> question.
>
> The ZF Gdata 1.10.8 component appears to work as a wrapper for Google
> Calendar Data API version 1.0. Is there a plan to move to join Java and .Net
> in making a wrapper for Google Calendar Data API version 2.0 which supports
> all of the Atom implementation (as I understand it).
>
> If anyone can point me in the right direction to find the answer to that I'd
> be obliged.
>
> Paul
> --
> View this message in context: http://zend-framework-community.634137.n4.nabble.com/Google-Data-API-version-2-compatability-is-it-planned-tp2550756p2550756.html
> Sent from the Zend gdata mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Google Data API version 2 compatability, is it planned?

PaulG
This post has NOT been accepted by the mailing list yet.
Chua,

I am especially interested in using the batch processing that v2 offers, has your solution encompassed this?

If so, are you willing to shared some code?

Thanks

Paul
Reply | Threaded
Open this post in threaded view
|

Re: Google Data API version 2 compatability, is it planned?

cheeze
Hi Paul,

Sorry for the late reply. Had a major hangover during the weekend.

I've only got the batch operation working for Docs ACL and Calendar batch mode.

The code was created off the 1.8 version of the library. So you'd want to do a diff against version 1.8.4 if you want to get the diff.

You can get the file from http://rojakcoder.com/Gdata.zip

Please feel free to email me if you have any questions about the code.